#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[[:space:]]*(imp33|imp44)[[:space:]]*$"
Local $sString = "#" & @CRLF & _
"" & @CRLF & _
"javi_2223" & @CRLF & _
"javi55_555" & @CRLF & _
"imp33" & @CRLF & _
"imp44" & @CRLF & _
"javi32423" & @CRLF & _
"javi5646"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")