import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[[:space:]]*(imp33|imp44)[[:space:]]*$";
final String string = "#\n\n"
+ "javi_2223\n"
+ "javi55_555\n"
+ "imp33\n"
+ "imp44\n"
+ "javi32423\n"
+ "javi5646";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}