const regex = /^[[:space:]]*(imp33|imp44)[[:space:]]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[[:space:]]*(imp33|imp44)[[:space:]]*$', 'gm')
const str = `#
javi_2223
javi55_555
imp33
imp44
javi32423
javi5646`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}