re = /^[[:space:]]*(imp33|imp44)[[:space:]]*$/m
str = '#
javi_2223
javi55_555
imp33
imp44
javi32423
javi5646'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end