package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[[:space:]]*(imp33|imp44)[[:space:]]*$`)
var str = `#
javi_2223
javi55_555
imp33
imp44
javi32423
javi5646`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}