using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+(?:\.\d+)?(?:\s+\d+(?:\.\d+)?)*$";
string input = @"3900 156.2 140.38 200 10
10 20 Hello
12345
12345.0 4.5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}