package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:\.\d+)?(?:\s+\d+(?:\.\d+)?)*$`)
var str = `3900 156.2 140.38 200 10
10 20 Hello
12345
12345.0 4.5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}