re = /^\d+(?:\.\d+)?(?:\s+\d+(?:\.\d+)?)*$/m
str = '3900 156.2 140.38 200 10
10 20 Hello
12345
12345.0 4.5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end