$re = '/^\d+(?:\.\d+)?(?:\s+\d+(?:\.\d+)?)*$/m';
$str = '3900 156.2 140.38 200 10
10 20 Hello
12345
12345.0 4.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);