// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(?:\.\d+)?(?:\s+\d+(?:\.\d+)?)*$").unwrap();
let string = "3900 156.2 140.38 200 10
10 20 Hello
12345
12345.0 4.5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}