# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{1,4}\s*kJs\b//gm;t' <<< "400kJs and 1000kJs"