$re = '/\d{1,4}\s*kJs\b/m';
$str = '400kJs and 1000kJs';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;