using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\d\.]+)\s+([\d\.]+)";
string input = @"20.3 22.0 19.5 NA NA 30.9 30.2 33.8 29.5 NA NA
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}