$re = '/([\d\.]+)\s+([\d\.]+)/m';
$str = '20.3 22.0 19.5 NA NA 30.9 30.2 33.8 29.5 NA NA
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);