re = /([\d\.]+)\s+([\d\.]+)/m
str = '20.3 22.0 19.5 NA NA 30.9 30.2 33.8 29.5 NA NA
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end