package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\d\.]+)\s+([\d\.]+)`)
var str = `20.3 22.0 19.5 NA NA 30.9 30.2 33.8 29.5 NA NA
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}