// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\d\.]+)\s+([\d\.]+)").unwrap();
let string = "20.3 22.0 19.5 NA NA 30.9 30.2 33.8 29.5 NA NA
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}