package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\/([\w\d]+)\?)`)
var str = `https://www.notion.so/owoy/a74a111111111111b55dafa3512d1c4d?v=b012aaaaac7d4cf7a07cf76c3c11111c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}