// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\/([\w\d]+)\?)").unwrap();
let string = "https://www.notion.so/owoy/a74a111111111111b55dafa3512d1c4d?v=b012aaaaac7d4cf7a07cf76c3c11111c";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}