import re
regex = re.compile(r"(?:\/([\w\d]+)\?)", flags=re.MULTILINE)
test_str = "https://www.notion.so/owoy/a74a111111111111b55dafa3512d1c4d?v=b012aaaaac7d4cf7a07cf76c3c11111c"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")