$re = '/(?:\/([\w\d]+)\?)/m';
$str = 'https://www.notion.so/owoy/a74a111111111111b55dafa3512d1c4d?v=b012aaaaac7d4cf7a07cf76c3c11111c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);