#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{2} de ((Jan|Fever)eiro|(Març|Mai)o|Abril|Ju[ln]ho|Agosto|(Setem|Outu|Novem|Dezem)bro) de \d{4}.+\d{2}:\d{2}:\d{2}"
Local $sString = "17 de Janeiro de 2008 às 11:35:04" & @CRLF & _
"17 de Fevereiro de 2008 às 11:35:04" & @CRLF & _
"17 de Março de 2008 às 11:35:04" & @CRLF & _
"17 de Abril de 2008 às 11:35:04" & @CRLF & _
"17 de Maio de 2008 às 11:35:04" & @CRLF & _
"17 de Junho de 2008 às 11:35:04" & @CRLF & _
"17 de Julho de 2008 às 11:35:04" & @CRLF & _
"17 de Agosto de 2008 às 11:35:04" & @CRLF & _
"17 de Setembro de 2008 às 11:35:04" & @CRLF & _
"17 de Outubro de 2008 às 11:35:04" & @CRLF & _
"17 de Novembro de 2008 às 11:35:04" & @CRLF & _
"17 de Dezembro de 2008 às 11:35:04" & @CRLF & _
"17 de mêsInválido de 2008 às 11:35:04" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")