use strict;
my $str = '17 de Janeiro de 2008 às 11:35:04
17 de Fevereiro de 2008 às 11:35:04
17 de Março de 2008 às 11:35:04
17 de Abril de 2008 às 11:35:04
17 de Maio de 2008 às 11:35:04
17 de Junho de 2008 às 11:35:04
17 de Julho de 2008 às 11:35:04
17 de Agosto de 2008 às 11:35:04
17 de Setembro de 2008 às 11:35:04
17 de Outubro de 2008 às 11:35:04
17 de Novembro de 2008 às 11:35:04
17 de Dezembro de 2008 às 11:35:04
17 de mêsInválido de 2008 às 11:35:04
';
my $regex = qr/\d{2} de ((Jan|Fever)eiro|(Març|Mai)o|Abril|Ju[ln]ho|Agosto|(Setem|Outu|Novem|Dezem)bro) de \d{4}.+\d{2}:\d{2}:\d{2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}