import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2} de ((Jan|Fever)eiro|(Març|Mai)o|Abril|Ju[ln]ho|Agosto|(Setem|Outu|Novem|Dezem)bro) de \\d{4}.+\\d{2}:\\d{2}:\\d{2}";
final String string = "17 de Janeiro de 2008 às 11:35:04\n"
+ "17 de Fevereiro de 2008 às 11:35:04\n"
+ "17 de Março de 2008 às 11:35:04\n"
+ "17 de Abril de 2008 às 11:35:04\n"
+ "17 de Maio de 2008 às 11:35:04\n"
+ "17 de Junho de 2008 às 11:35:04\n"
+ "17 de Julho de 2008 às 11:35:04\n"
+ "17 de Agosto de 2008 às 11:35:04\n"
+ "17 de Setembro de 2008 às 11:35:04\n"
+ "17 de Outubro de 2008 às 11:35:04\n"
+ "17 de Novembro de 2008 às 11:35:04\n"
+ "17 de Dezembro de 2008 às 11:35:04\n"
+ "17 de mêsInválido de 2008 às 11:35:04\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}