const regex = /\d{2} de ((Jan|Fever)eiro|(Març|Mai)o|Abril|Ju[ln]ho|Agosto|(Setem|Outu|Novem|Dezem)bro) de \d{4}.+\d{2}:\d{2}:\d{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{2} de ((Jan|Fever)eiro|(Març|Mai)o|Abril|Ju[ln]ho|Agosto|(Setem|Outu|Novem|Dezem)bro) de \\d{4}.+\\d{2}:\\d{2}:\\d{2}', 'gm')
const str = `17 de Janeiro de 2008 às 11:35:04
17 de Fevereiro de 2008 às 11:35:04
17 de Março de 2008 às 11:35:04
17 de Abril de 2008 às 11:35:04
17 de Maio de 2008 às 11:35:04
17 de Junho de 2008 às 11:35:04
17 de Julho de 2008 às 11:35:04
17 de Agosto de 2008 às 11:35:04
17 de Setembro de 2008 às 11:35:04
17 de Outubro de 2008 às 11:35:04
17 de Novembro de 2008 às 11:35:04
17 de Dezembro de 2008 às 11:35:04
17 de mêsInválido de 2008 às 11:35:04
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}