using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\s+(?<your_field>[^:]+)";
string input = @"DBNAME : db001_inst1:schemanamexyx
DBNAME : db01_inst1:schemanamexyx";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}