package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):\s+(?<your_field>[^:]+)`)
var str = `DBNAME : db001_inst1:schemanamexyx
DBNAME : db01_inst1:schemanamexyx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}