const regex = /:\s+(?<your_field>[^:]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':\\s+(?<your_field>[^:]+)', 'gm')
const str = `DBNAME : db001_inst1:schemanamexyx
DBNAME : db01_inst1:schemanamexyx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}