$re = '/:\s+(?<your_field>[^:]+)/m';
$str = 'DBNAME : db001_inst1:schemanamexyx
DBNAME : db01_inst1:schemanamexyx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);