re = /:\s+(?<your_field>[^:]+)/m
str = 'DBNAME : db001_inst1:schemanamexyx
DBNAME : db01_inst1:schemanamexyx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end