import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(ATG)((A|C|G|T){3})+(TAA|TAG|TGA)$";
final String string = "ATGTAG\n"
+ "ATGTAGATGTAG\n"
+ "TAGATGTAGATGTAG\n"
+ "ATGTAGATGTAGA\n"
+ "ATGTAGAAAATGTAG\n"
+ "ATGTAGAAATGTAG\n"
+ "ATGACGTAG\n"
+ "ATGACGTAG\n"
+ "ATGACGTAAATGACGTAG\n"
+ "ATG\n"
+ "ATGACTGTAA\n"
+ "TGAATGACGTAA\n"
+ "ATGACGTAG ATGACGTGA\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}