$re = '/^(ATG)((A|C|G|T){3})+(TAA|TAG|TGA)$/m';
$str = 'ATGTAG
ATGTAGATGTAG
TAGATGTAGATGTAG
ATGTAGATGTAGA
ATGTAGAAAATGTAG
ATGTAGAAATGTAG
ATGACGTAG
ATGACGTAG
ATGACGTAAATGACGTAG
ATG
ATGACTGTAA
TGAATGACGTAA
ATGACGTAG ATGACGTGA
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);