// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(ATG)((A|C|G|T){3})+(TAA|TAG|TGA)$").unwrap();
let string = "ATGTAG
ATGTAGATGTAG
TAGATGTAGATGTAG
ATGTAGATGTAGA
ATGTAGAAAATGTAG
ATGTAGAAATGTAG
ATGACGTAG
ATGACGTAG
ATGACGTAAATGACGTAG
ATG
ATGACTGTAA
TGAATGACGTAA
ATGACGTAG ATGACGTGA
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}