re = /^(ATG)((A|C|G|T){3})+(TAA|TAG|TGA)$/m
str = 'ATGTAG
ATGTAGATGTAG
TAGATGTAGATGTAG
ATGTAGATGTAGA
ATGTAGAAAATGTAG
ATGTAGAAATGTAG
ATGACGTAG
ATGACGTAG
ATGACGTAAATGACGTAG
ATG
ATGACTGTAA
TGAATGACGTAA
ATGACGTAG ATGACGTGA
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end