import re
regex = re.compile(r"^(ATG)((A|C|G|T){3})+(TAA|TAG|TGA)$", flags=re.MULTILINE)
test_str = ("ATGTAG\n"
"ATGTAGATGTAG\n"
"TAGATGTAGATGTAG\n"
"ATGTAGATGTAGA\n"
"ATGTAGAAAATGTAG\n"
"ATGTAGAAATGTAG\n"
"ATGACGTAG\n"
"ATGACGTAG\n"
"ATGACGTAAATGACGTAG\n"
"ATG\n"
"ATGACTGTAA\n"
"TGAATGACGTAA\n"
"ATGACGTAG ATGACGTGA\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")