#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[\s\S]+?(?<!\d)(\d{8})(?!\d)"
Local $sString = "Test123456789 -- should fail because 9 digits" & @CRLF & _
"" & @CRLF & _
"Test23456789Test -- pass" & @CRLF & _
"" & @CRLF & _
"Test23456789 Test -- pass" & @CRLF & _
"" & @CRLF & _
"13456780Test -- pass" & @CRLF & _
"" & @CRLF & _
"Test0123456 -- fail because 7 digits" & @CRLF & _
"" & @CRLF & _
"Extra text in the email: I’ve attached the information you requested. If you have any questions, please let us know. -- extra text in the email shouldn't matter."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")