import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\s\\S]+?(?<!\\d)(\\d{8})(?!\\d)";
final String string = "Test123456789 -- should fail because 9 digits\n\n"
+ "Test23456789Test -- pass\n\n"
+ "Test23456789 Test -- pass\n\n"
+ "13456780Test -- pass\n\n"
+ "Test0123456 -- fail because 7 digits\n\n"
+ "Extra text in the email: I’ve attached the information you requested. If you have any questions, please let us know. -- extra text in the email shouldn't matter.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}