import re
regex = re.compile(r"^[\s\S]+?(?<!\d)(\d{8})(?!\d)")
test_str = ("Test123456789 -- should fail because 9 digits\n\n"
"Test23456789Test -- pass\n\n"
"Test23456789 Test -- pass\n\n"
"13456780Test -- pass\n\n"
"Test0123456 -- fail because 7 digits\n\n"
"Extra text in the email: I’ve attached the information you requested. If you have any questions, please let us know. -- extra text in the email shouldn't matter.")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")