re = /^[\s\S]+?(?<!\d)(\d{8})(?!\d)/
str = 'Test123456789 -- should fail because 9 digits
Test23456789Test -- pass
Test23456789 Test -- pass
13456780Test -- pass
Test0123456 -- fail because 7 digits
Extra text in the email: I’ve attached the information you requested. If you have any questions, please let us know. -- extra text in the email shouldn\'t matter.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end