const regex = /^[\s\S]+?(?<!\d)(\d{8})(?!\d)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\s\\S]+?(?<!\\d)(\\d{8})(?!\\d)', '')
const str = `Test123456789 -- should fail because 9 digits
Test23456789Test -- pass
Test23456789 Test -- pass
13456780Test -- pass
Test0123456 -- fail because 7 digits
Extra text in the email: I’ve attached the information you requested. If you have any questions, please let us know. -- extra text in the email shouldn't matter.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}