#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:>|<(?!.*<))?[a-zA-Z]+(?:(?:\+|-)\d*\.?\d*(?:em)?)?)(?:<?[a-zA-Z]+(?:(?:\+|-)\d*\.?\d*(?:em)?)?)?$"
Local $sString = "<alpha<bravo" & @CRLF & _
"alpha" & @CRLF & _
"alphaBravo" & @CRLF & _
"alphaBravoCharlie" & @CRLF & _
">alpha" & @CRLF & _
"<alpha" & @CRLF & _
">alpha+10" & @CRLF & _
"<alpha+10" & @CRLF & _
">alpha+1.5" & @CRLF & _
"<alpha+1.5" & @CRLF & _
">alpha-10" & @CRLF & _
">alpha-10" & @CRLF & _
">alpha-1.5" & @CRLF & _
">alpha-1.5" & @CRLF & _
">alpha+10em" & @CRLF & _
"<alpha+10em" & @CRLF & _
">alpha+1.5em" & @CRLF & _
"<alpha+1.5em" & @CRLF & _
">alpha-1.5em" & @CRLF & _
">alpha-1.5em" & @CRLF & _
"alpha-50em<delta-100em" & @CRLF & _
"alpha-50em<delta+100em" & @CRLF & _
">alpha-50em<delta+100em" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")