const regex = /^(?:(?:>|<(?!.*<))?[a-zA-Z]+(?:(?:\+|-)\d*\.?\d*(?:em)?)?)(?:<?[a-zA-Z]+(?:(?:\+|-)\d*\.?\d*(?:em)?)?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:>|<(?!.*<))?[a-zA-Z]+(?:(?:\\+|-)\\d*\\.?\\d*(?:em)?)?)(?:<?[a-zA-Z]+(?:(?:\\+|-)\\d*\\.?\\d*(?:em)?)?)?$', 'gm')
const str = `<alpha<bravo
alpha
alphaBravo
alphaBravoCharlie
>alpha
<alpha
>alpha+10
<alpha+10
>alpha+1.5
<alpha+1.5
>alpha-10
>alpha-10
>alpha-1.5
>alpha-1.5
>alpha+10em
<alpha+10em
>alpha+1.5em
<alpha+1.5em
>alpha-1.5em
>alpha-1.5em
alpha-50em<delta-100em
alpha-50em<delta+100em
>alpha-50em<delta+100em
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}