using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:>|<(?!.*<))?[a-zA-Z]+(?:(?:\+|-)\d*\.?\d*(?:em)?)?)(?:<?[a-zA-Z]+(?:(?:\+|-)\d*\.?\d*(?:em)?)?)?$";
string input = @"<alpha<bravo
alpha
alphaBravo
alphaBravoCharlie
>alpha
<alpha
>alpha+10
<alpha+10
>alpha+1.5
<alpha+1.5
>alpha-10
>alpha-10
>alpha-1.5
>alpha-1.5
>alpha+10em
<alpha+10em
>alpha+1.5em
<alpha+1.5em
>alpha-1.5em
>alpha-1.5em
alpha-50em<delta-100em
alpha-50em<delta+100em
>alpha-50em<delta+100em
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}