import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:>|<(?!.*<))?[a-zA-Z]+(?:(?:\\+|-)\\d*\\.?\\d*(?:em)?)?)(?:<?[a-zA-Z]+(?:(?:\\+|-)\\d*\\.?\\d*(?:em)?)?)?$";
final String string = "<alpha<bravo\n"
+ "alpha\n"
+ "alphaBravo\n"
+ "alphaBravoCharlie\n"
+ ">alpha\n"
+ "<alpha\n"
+ ">alpha+10\n"
+ "<alpha+10\n"
+ ">alpha+1.5\n"
+ "<alpha+1.5\n"
+ ">alpha-10\n"
+ ">alpha-10\n"
+ ">alpha-1.5\n"
+ ">alpha-1.5\n"
+ ">alpha+10em\n"
+ "<alpha+10em\n"
+ ">alpha+1.5em\n"
+ "<alpha+1.5em\n"
+ ">alpha-1.5em\n"
+ ">alpha-1.5em\n"
+ "alpha-50em<delta-100em\n"
+ "alpha-50em<delta+100em\n"
+ ">alpha-50em<delta+100em\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}