import Foundation
let pattern = #"^(?:(?:>|<(?!.*<))?[a-zA-Z]+(?:(?:\+|-)\d*\.?\d*(?:em)?)?)(?:<?[a-zA-Z]+(?:(?:\+|-)\d*\.?\d*(?:em)?)?)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<alpha<bravo
alpha
alphaBravo
alphaBravoCharlie
>alpha
<alpha
>alpha+10
<alpha+10
>alpha+1.5
<alpha+1.5
>alpha-10
>alpha-10
>alpha-1.5
>alpha-1.5
>alpha+10em
<alpha+10em
>alpha+1.5em
<alpha+1.5em
>alpha-1.5em
>alpha-1.5em
alpha-50em<delta-100em
alpha-50em<delta+100em
>alpha-50em<delta+100em
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)