# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+day-(\d{4}-\d{1,2}-\d{1,2})--.*/\1/gm;t' <<< "2day-2023-1-5--20-0.csv
1day-2023-2-5--20-0.csv
3day-2021-1-5--20-0.csv
103day-2021-1-5--20-0.csv"