use strict;
my $str = '2day-2023-1-5--20-0.csv
1day-2023-2-5--20-0.csv
3day-2021-1-5--20-0.csv
103day-2021-1-5--20-0.csv';
my $regex = qr/\d+day-(\d{4}-\d{1,2}-\d{1,2})--.*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";