using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+day-(\d{4}-\d{1,2}-\d{1,2})--.*";
string substitution = @"\1";
string input = @"2day-2023-1-5--20-0.csv
1day-2023-2-5--20-0.csv
3day-2021-1-5--20-0.csv
103day-2021-1-5--20-0.csv";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}