re = /\d+day-(\d{4}-\d{1,2}-\d{1,2})--.*/m
str = '2day-2023-1-5--20-0.csv
1day-2023-2-5--20-0.csv
3day-2021-1-5--20-0.csv
103day-2021-1-5--20-0.csv'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result