#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d+day-(\d{4}-\d{1,2}-\d{1,2})--.*"
Local $sString = "2day-2023-1-5--20-0.csv" & @CRLF & _
"1day-2023-2-5--20-0.csv" & @CRLF & _
"3day-2021-1-5--20-0.csv" & @CRLF & _
"103day-2021-1-5--20-0.csv"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)